-
Type: Improvement
-
Status: Closed (View Workflow)
-
Priority: Minor
-
Resolution: Fixed
-
Affects Version/s: 0.3
-
Fix Version/s: 0.4
-
Labels:None
-
Environment:
Default
(Initially created as http://fisheye.jtalks.org/cru/JC-45 but I don't know it is visible for all or not, so I create this ticket.)
One idea about this line: https://github.com/jtalks-org/jtalks/commit/c9eefeef9ebd0b97e40c390824c107e7171ff6c5#L1R174
If we are using slf4j so why not use placeholders which made code more readable and faster in some circumstances?
So, instead of
>logger.debug("Deleted securedObject " + clazz + " with id: " + id);
I suggest to write
>logger.debug("Deleted securedObject {} with id: {}", clazz, id);
See http://www.slf4j.org/faq.html#logging_performance
(Also, this probably should me changed in all source base.)